Background Image

Performance tips and base knowledge

Discussion in 'General Discussion' started by CrocoFred, Sep 28, 2016.

  1. Orderdrake1546 Orderdrake1546 Steam Early Access

    I hear this a lot which is boggling to me. I had a amd 840T crappy quad core and a 560ti all stock clocks and was getting smooth fps and no lag. Just the known 5 second stalls. Maybe it has something to do with dx12 or something?
  2. Marky Dodo Steam Early Access

    Ok, I have managed to RAR the kernel memory dump (took a while to find even with the guide xD) and have put in to my dropbox. here is the link.
    https://www.dropbox.com/s/8by70jw1yy6xgld/102616-31671-01.rar?dl=0

    This error only occurs on EC, no idea why. I may try reinstalling EC and see if that does the trick ^^
  3. Hædron Haedron Curator

    Alright, from what I can gather, the faulting components are the directx kernel (dxgkrnl) and your video card driver (nvlddmkm), which is just what we thought all along, right? The problem around nvlddmkm usually revolves around the display driver stopping to respond, then recovering:

    Event 4101, Display: Display driver nvlddmkm stopped responding and has successfully recovered.

    This might appear in your laptops event log as well, which you should check to make sure it is related. As the fault is power state related, you might want to make sure you correctly followed @FaintlyLucky 's advice to look into the power options. To do so, right click on the battery symbol in the lower right corner of your desktop, and click on Power Options. Make sure the plan is set to high performance, then click on the advanced settings. Follow this picture and compare the settings:

    [​IMG]

    Confirm everything with OK. Your NVIDIA settings might not have had any influence on Windows' behaviour towards this end.

    If this does not remedy your problem, you definitely should:

    - update your system BIOS
    - update your mainboard/chipset drivers (should be Intel HM170), because that can never hurt
    - wipe all of your NVIDIA drivers using this tool
    - then reinstall your graphics drivers, ideally fresh from NVIDIA's home page

    Concerning the drivers, the pc specialist homepage is absolute garbage. I could not for the life of me find anything driver related, let alone a fitting BIOS for what those ****** sell. You can download a tool from the intel homepage that will scan your system for its chipset, so that should be covered. As for the BIOS, their support would have to help you, sorry!

    I truly hope what little I could gather helps you - it's not much, and not a universal solution that will 100% fix it, I am aware. But to fix such errors, going about it in a methodical manner is (in my opinion) quite necessary. Fingers crossed!
  4. spudthegreat Recruit

    Just wanted to see if anyone else has been having terrible performance since the most recent patch. I have been playing EC for months now, and been stable 55+fps the entire time, never dipped below that. Most recent patch I'm getting 1-10fps and it's unplayable. All other games are fine, Witcher 3, Just Cause 3, GTAV etc. My specs:

    Intel i5 4750
    16G RAM
    GTX 970
    Samsung 850EVO ssd

    Cheers.
  5. swankie swankie Steam Early Access

    http://steamcharts.com/app/375230

    first off i agree with ambassador pineapple. second you can see when you click this link how shitty this game has gotten. No wonder it takes forever in que, because NO ONE IS PLAYING THE GAME! BEHavior you really screwed this up. Oh and NO ONE WANTS TO WATCH YOU PLAY YOUR OWN GAME DURING YOUR STREAMS! Just answer our questions and give us the updates. Also if that long haired skinny glasses wearing jerk says "yeah, yeah, yeah" to one of the devs trying to explain something to us again im going to flip my lid. STOP BEING RUDE! When they finally are telling us something worth while and all you can do is say "yeah, yeah, yeah," or "what was the question" because you arent paying attention to the people that are paying you to be there. damn get some manners.[​IMG]
  6. USSRxGrabli USSRxGrabli Arkhona Vanguard

    My specs:
    AMD FX 8320
    8 Gb RAM
    RX470
    SSD Kingston KC400 [SKC400S37/256G]

    Im plaing game all time with AMD Gaming Evolved.
    So i have all time 50-60 FPS.
    I had similar to your problem situation once. But it helped to restart the PC.

    Wow-wow. Be easy. There are was 13,547 ± 2,978 players in the last 2 weeks.


  7. Bladerunner Bladerunner777 Well-Known Member

    Wow (don't mistake with WoW :D )
  8. Marky Dodo Steam Early Access

    Good news everyone! thanks to reinstalling Nvidea graphics driver and doing updates through that (plus a java update) I have manged to play 4 games without crashing! it still pauses at the loaidng screen but by having nvidea up, it seems to smooth it somewhat. here is hoping that I do not crash again! thank you all for the help =D
    Haedron likes this.
  9. Octave Octave First Blood!

    After all this time i really can't say that i'm impressed with the optimization of this game. Some progresses have been made, let's be fair, they have added some options and all, thanks for that but so little in terms of improvement, so little.
    Kell likes this.
  10. Dolf Dolf Preacher

    Anyone experience with R9-290? Performs very badly, forced to play on lowest settings im not enjoying the game at all. The game doesn't even look that good to be using up so much power. Ive played a better looking games on high settings.

    Operating System: Windows 10 Pro 64-bit (10.0, Build 14393) (14393.rs1_release.161220-1747)
    System Model: MS-7821
    BIOS: BIOS Date: 07/21/14 11:03:17 Ver: V1.9B0
    Processor: Intel(R) Core(TM) i5-4670K CPU @ 3.40GHz (4 CPUs), ~3.4GHz
    GPU: MSI R9-290
    Memory: 16384MB RAM
    Available OS Memory: 16328MB RAM
    Page File: 3847MB used, 14912MB available
    DirectX Version: DirectX 12

    The worse thing is even if it shows around 30-40 fps it feels like 20.

Share This Page